first of all, thanks for your interest in "Samsung Tools" project, which is rather slack at the moment (along with the whole project "Linux On My Samsung"). The main reason is that I've lost interest, I'm starting to dislike Samsung products, and it just does not feel right to waste my time to fix their products.
The "Samsung Tools" code is far from perfect, it was written in a fast way to make it usable in short times. In fact, the first thing in my TODO list was code refactoring (which I never did for the said lack of interest).
That said, I was looking at your changes, they seem good to me except for some "simplifications" you did which in result make the code harder to read, and I prefer readability over the syntesis.
For example, you changed this:
with open(SL_PATH_BACKLIGHT, 'r') as file:
status = int(file.read(1))
if status == 0:
return not bool(int(rFile(SL_PATH_BACKLIGHT)))
I don't like it.
If you provide me with a proper patch that I can apply to the bzr branch, I would be happy to apply it.
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!