Last visit was: It is currently 30/07/2014, 8:02


All times are UTC [ DST ]




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Sleep or Suspend and Resume issues on Samsung NC10?
PostPosted: 25/05/2010, 20:44 
Newbie
Newbie

Joined: 25/05/2010, 20:21
Posts: 2
Has anyone else on these forums had trouble with Suspend/Resume on their NC10? I'm running a relatively fresh install of 10.04 with the latest Kernal on my NC10 (with most recent BIOS) and am still having trouble suspending and resuming.

The only setup that works for me is when I suspend from the system menu with my AC cord plugged in. When I select this option, the screen saver comes on for one or two seconds and then the computer goes to sleep. When it wakes back up, the screen saver is on for a moment and then I get the "screen unlock" screen where I have to enter my password.

If I do anything differently (no AC cord, pressing the "Sleep key" (Fn + F1) and by closing the lid) then I'm unable to resume. When I awaken the computer (using the power button) I get only a blank screen and cannot use any controls. I'm forced to shutdown by holding down the power key. Interestingly, suspending using these settings (no AC cord, or by pressing the sleep key, or by closing the lid) doesn't turn on the screen saver for a split second either. It seems that when the screen saver turns on during the suspend process, then I'll be able to wake back up.

Does anyone have any ideas where I should go from here? I'm getting the idea that everyone else has worked out a solution to this problem, except me. For what it's worth, I've updated the repository following the guide on these forums. That hasn't fixed the problem. As far as I know, everything else on the computer (volume controls, screen brightness, etc) works fine. Thanks in advance for any guidance you guys can provide.


Top
 Profile  
 
 Post subject: Re: Sleep or Suspend and Resume issues on Samsung NC10?
PostPosted: 29/05/2010, 13:04 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
Sorry for the late answer, I've been a little busy these days. :(

So, accordingly to what you have described, it seems that you have some misconfiguration in your power management.
In some cases the suspend is managed by the gnome-power daemon, which takes all steps needed for a correct suspend cycle (one of them is to activate the screensaver) and at resume everything is ok, in other cases it's like the gnome-power daemon is not used and the suspend cycle fails.

Take a look at the 'gnome-power-manager' options and check they are all correct, also look at its advanced options by using the 'gconf-editor' utility (options are in /apps/gnome-power-manager).

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net & kodeki