Last visit was: It is currently 22/10/2014, 5:50


All times are UTC [ DST ]




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: help with wireless nb30
PostPosted: 31/05/2010, 17:42 
Newbie
Newbie

Joined: 31/05/2010, 17:33
Posts: 6
Just got my NB30 yesterday, and being of the ubuntu culture thought I would try UNR Lucid. It installed flawlessly. I do have a problem with the wireless and function keys . Searching the web brought me here, it seems all of the resources to fix my issues are here. Alas, this however is the problem:

I have dial up internet, the router and network are not connected to the internet (because it is dial up), so I have no way of connecting the nb30 directly to internet. The only other access i have to internet is when I am at hotels, and that is wireless only as well. My question is, how do i get the wireless up and running without internet available? I have tried to download the package from your repository directly to another computer and then transferring them to the nb30 but that yields some dependency issues. If anyone has any ideas I am all ears :)

BTW, great work on this site, fantastic resources.

FOD


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 31/05/2010, 18:30 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
Hi and welcome to the forum. :)

I think all you need in order to have wireless up and running is the 'samsung-wireless' package from my repository.
What are the missing dependencies the package manager complains of?

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 31/05/2010, 18:37 
Newbie
Newbie

Joined: 31/05/2010, 17:33
Posts: 6
I downloaded samsung-wireless_2.6.32-22~ppa2~loms~locid_all.deb and when i run it with the package manager i get :
Error: Dependency is not satisfiable: samsung-wireless-2.6.32-22

I am UNR 10.4 without any updates, i believe the kernel i've got is -21.

I am not an advanced linux user, so forgive my ignorance if I have to ask some stupid questions ;)

Fod


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 31/05/2010, 18:51 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
You need to download both 'samsung-wireless' and 'samsung-wireless-2.6.32-22' .deb packages from the repository.

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 31/05/2010, 19:02 
Newbie
Newbie

Joined: 31/05/2010, 17:33
Posts: 6
Thank you for the quick replies,

So with both files in downloaded and placed in my home folder when I try to install samsung-wireless-2.6.32-22_2.6.32-22~ppa2~loms~lucid_i386.deb it gives me:

Error: Dependency is not satisfiable: linux-image-2.6.32-22-generic

My guess is because I am running the -21 kernel? If I try the karmic wireless files in your repository will that create some problems?

Thanks again,

fod


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 31/05/2010, 20:25 
Newbie
Newbie

Joined: 31/05/2010, 17:33
Posts: 6
never mind about the karmic files, those are a different linux kernel. Can someone direct me on how to download the kernel that matches the wireless files in this repository on another computer and then install it on the netbook? is that even possible?

thank you

fod


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 01/06/2010, 6:39 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
The 'samsung-wireless' available on the repository is built against the latest official kernel available for Lucid, so you need to install it first.

In general, you can manually download official .deb packages from http://packages.ubuntu.com/ or from http://launchpad.net.

You need these packages:
- linux-image-2.6.32-22-generic
- linux-headers-2.6.32-22
- linux-headers-2.6.32-22-generic

Install them in this order. Then you should be able to install 'samsung-wireless' packages and, if everything is ok, your wireless connection should start to work. Once you have working wireless connection, follow these instructions to properly add my repository to your system and perform a full system update.

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
 Post subject: Re: help with wireless nb30
PostPosted: 04/06/2010, 15:04 
Newbie
Newbie

Joined: 31/05/2010, 17:33
Posts: 6
it is all working now

many many many thanks.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net & kodeki