Last visit was: It is currently 02/09/2014, 3:03


All times are UTC [ DST ]




Post new topic Reply to topic  [ 53 posts ]  Go to page Previous  1, 2, 3, 4  Next
Author Message
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 08/03/2009, 15:01 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
Anyway, I did more testing with the wireless card and my linux-backports-modules package. I also tested a newer driver snapshot (2009-03-07) but unfortunately the results are the same for me.

Setting the bitrate to auto makes it growing up from 1M to 24M. 36M or more simply fails. The problem with the auto setting is that sometime the driver tries to go on 36M or more, and this causes some little hangs with the connection. So, the best solution for me is to set up the bitrate to '24M auto'.

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Last edited by voRia on 09/03/2009, 0:09, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 08/03/2009, 15:30 
Newbie
Newbie

Joined: 17/02/2009, 10:11
Posts: 29
'voRia' pid='253' dateline='1236346164' wrote:
Then try the new kernel, you can take it directly from jaunty, you have to just download the deb file (link) and install it. :)
It will not replace your current kernel and, if any problem, you can uninstall it through the package manager.

Maybe you will need the linux-backports-modules package for the new kernel, you can find it here. :)

Good luck ;)


voRia,
Grazie mille!
1.
Fist compiled latest sources as guidede here:
http://www.ubuntugeek.com/how-to-get-at ... -ibex.html
No luck! ath5k could not be modprobed anymore. Unloaded this thing.
2.
Did the kernel 28 trick as guided by voRia. Jaunty packages needed were:
wireless-crda_1.6_i386.deb
linux-image-3.6.28-8.........deb
linux-backports-modules-2.6.28- ......deb
Now my wlan works in good speed, less any forcing to 11M by iwconfig or added rows to /etc/rc.local.
At least my home wlan works now fine. Dont know about others. Yes: before I had wlan issues for instance in the library of my home city. Hopefully these issues are gone now too? Will see.

Adesso, sono contento. Grazie voRia!
redu


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 08/03/2009, 16:30 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
:)

Just checked, the linux-backports-modules package in jaunty is based on snapshot 2009-03-03 of ath5k module drivers.
I'm glad it works for you now :)
When you'll check the wlan in your city's library, let me know if issues are gone there too! ;)

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Last edited by voRia on 08/03/2009, 16:30, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 10/03/2009, 19:59 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
I'm adding a new version of the linux-backports-modules package on my repository. As you can read in the changelog, I updated the driver sources to the latest snapshot available (2009-03-10).

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Last edited by voRia on 10/03/2009, 20:00, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 10/03/2009, 22:31 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
Unfortunately latest driver snapshot sometime fails to wake up the wireless card after a suspend/resume cycle (maybe due to the rfkill patch, I don't know). I'm reverting back to 2009-02-05 snapshot.

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 11/03/2009, 7:26 
Newbie
Newbie

Joined: 17/02/2009, 10:11
Posts: 29
'voRia' pid='294' dateline='1236711584' wrote:
I'm adding a new version of the linux-backports-modules package on my repository. As you can read in the changelog, I updated the driver sources to the latest snapshot available (2009-03-10).


This new backports made no difference in my wlan issue. Works like the original 27. kernel ath5k. Forcing to 11M required.

The Jaunty backports ath5k did well in my home wlan, but failed in the local library wlan? In the library, wlan was really sloooow.

Next project may be downloading a full jaunty alpha6 12.3. Or a full Jaunty beta 26.3.

redu


Last edited by redu on 11/03/2009, 7:27, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 12/03/2009, 23:55 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
'redu' pid='297' dateline='1236752789' wrote:
This new backports made no difference in my wlan issue. Works like the original 27. kernel ath5k. Forcing to 11M required.


It's normal, I reverted the package on my repository back to the previous snapshot (2009-02-05), due to a problem with latest versions, where the wireless card fails to wake up after a suspend/resume cycle.

Anyway, just to let you know, a new patchset has been posted on ath5k-devel mailing list that adds the tx power calibration support. I tried it and finally I got a full 54Mb connection with my wireless card... for just 1 minute, then it hanged completely the system. :P However, the funcionality is there. :)

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Last edited by voRia on 13/03/2009, 0:56, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 13/03/2009, 12:56 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
The problem with hanged system seems to be sorted out, I'm uploading the new linux-backports-modules package on my repository.
Here is the changelog:
Code:
linux-backports-modules-2.6.27 (2.6.27-13.15~ppa7~nc10) intrepid; urgency=low

  * Updated compat-wireless to master-2009-03-13
  * Applied patch to enable rfkill function (thanks to Tobias Doerffer)
  * Applied patch to fix a reset problem (thanks to Bob Copeland)
  * Applied patches for tx power calibration support (thanks to Nick
    Kossifidis, Felix Fietkau, Sam Leffler)

 -- Fortunato Ventre (voRia) <vorione@gmail.com>  Fri, 13 Mar 2009 11:57:54 +0100


Using the tx power calibration patches my card works at 54Mbit with no problems at all.
Please give it a try and let me know how it works for you. :)

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Last edited by voRia on 13/03/2009, 20:00, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 13/03/2009, 20:59 
Newbie
Newbie

Joined: 17/02/2009, 10:11
Posts: 29
'voRia' pid='334' dateline='1236945393' wrote:
The problem with hanged system seems to be sorted out, I'm uploading the new linux-backports-modules package on my repository.
Here is the changelog:
Code:
linux-backports-modules-2.6.27 (2.6.27-13.15~ppa7~nc10) intrepid; urgency=low

  * Updated compat-wireless to master-2009-03-13
  * Applied patch to enable rfkill function (thanks to Tobias Doerffer)
  * Applied patch to fix a reset problem (thanks to Bob Copeland)
  * Applied patches for tx power calibration support (thanks to Nick
    Kossifidis, Felix Fietkau, Sam Leffler)

 -- Fortunato Ventre (voRia) <vorione@gmail.com>  Fri, 13 Mar 2009 11:57:54 +0100


Using the tx power calibration patches my card works at 54Mbit with no problems at all.
Please give it a try and let me know how it works for you. :)


Thanks voRia,
these are great news! Would like to check, but:
I did a fresh install using Jaunty alpha6: Wlan worked out of the box! Brightness control-Fn worked out of the box. Audio volume level worked out of the box. Etc...
voRia mousepad vertical flattening is missing. Wifi switch off does not work. Two finger mouse does not work.

Unfortunately wlan does not reach 54M, and it still is really slow in local library wlan. And many packages are missing in jaunty repository, eg webcam, libdvdcss, etc...

How to add these new ath5k patches to jaunty alpha6?

redu


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 13/03/2009, 21:15 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
Download and extract the sources for the 'linux-backports-modules' package you are using.
Apply these patches (I have numbered them, the first one is for the rfkill function, the second one is for the reset problem, all the rest is for the tx power calibration).
Rebuild the package (with the 'dpkg-buildpackage' command from the root directory of the sources).

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Last edited by voRia on 13/03/2009, 21:17, edited 1 time in total.

Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 15/03/2009, 7:16 
Newbie
Newbie

Joined: 17/02/2009, 10:11
Posts: 29
'voRia' pid='342' dateline='1236975305' wrote:
Download and extract the sources for the 'linux-backports-modules' package you are using.
Apply these patches (I have numbered them, the first one is for the rfkill function, the second one is for the reset problem, all the rest is for the tx power calibration).
Rebuild the package (with the 'dpkg-buildpackage' command from the root directory of the sources).


thanks voRia,
but in my "out of the box" 9.04alpha6 system no 'linux-backports-modules' packages are installed! Not needed?

redu


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 15/03/2009, 10:48 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
I mean the 'linux-backports-modules' for the kernel you're using.
If I'm not wrong, latest on jaunty is linux-backports-modules-2.6.28-9-generic.

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 15/03/2009, 15:47 
Newbie
Newbie

Joined: 17/02/2009, 10:11
Posts: 29
'voRia' pid='357' dateline='1237110495' wrote:
I mean the 'linux-backports-modules' for the kernel you're using.
If I'm not wrong, latest on jaunty is linux-backports-modules-2.6.28-9-generic.


This is a mess for me:

~$ uname -r

2.6.28-9-generic


Packages in synaptic (not installed):

linux-backports-modules-2.6.28-9-generic

Ubuntu supplied Linux modules for version 2.6.28 on x86/x86_64
version 2.6.28-9.9

linux-backports-modules-jaunty-generic
version 2.6.28.9.9

Installed packages:

linux-image-generic
version 2.6.28.9.9

linux-headers-2.6.28-9
version 2.6.28-9.31

linux-headers-generic
version 2.6.28.9.9


redu


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 15/03/2009, 15:56 
Administrator
Administrator
User avatar

Joined: 12/02/2009, 18:08
Posts: 1377
Location: Italy
You are using the default ath5k module included in the kernel package.
To use a newer module, install the 'linux-backports-modules-jaunty' package (that automatically will install the specific 'linux-backports-modules' package for your kernel).
If you want to apply the patches for the tx power calibration, get the sources, patch and rebuild them, then install the new .deb file.

_________________
Please consider a little donation to keep the 'Linux On My Samsung' project up and running. Thank you!


Top
 Profile  
 
 Post subject: RE: [nc 10] Wlan issues
PostPosted: 16/03/2009, 8:29 
Newbie
Newbie

Joined: 17/02/2009, 10:11
Posts: 29
'voRia' pid='371' dateline='1237128970' wrote:
You are using the default ath5k module included in the kernel package.
To use a newer module, install the 'linux-backports-modules-jaunty' package (that automatically will install the specific 'linux-backports-modules' package for your kernel).
If you want to apply the patches for the tx power calibration, get the sources, patch and rebuild them, then install the new .deb file.

voRia,
tried adding patches to linux sources, but lots of error messages were generated. No luck? In the names of patches, there should not be spaces. Eg 1 - xxxxxx > 1-xxxxx

redu


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 53 posts ]  Go to page Previous  1, 2, 3, 4  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net & kodeki