Last visit was: It is currently 19/04/2014, 5:33


All times are UTC [ DST ]




Post new topic Reply to topic  [ 84 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next
Author Message
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 17/02/2011, 1:01 
Newbie
Newbie

Joined: 03/02/2011, 17:52
Posts: 6
ok, i tried the workaround once again. i dont exactly have problems with flickering but how i told before, i cant control brightness with fn-keys + hibernation sometimes crashes...

so here is what i did by following the workaround (after updating the whole system):

1) in /etc/default/grub following line modified from
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor intel_idle.max_cstate=0"
2) sudo update-grub; sudo update-initramfs -u
3) added the following text to the end of /etc/modprobe.d/blacklist.conf: blacklist samsung-backlight
4)edited /etc/rc.local and paste before the "exit 0" statement: modprobe samsung-backlight
5) created a file called /etc/pm/config.d/unload_modules containing: SUSPEND_MODULES="samsung-backlight"

i also tried to uninstall an reinstall samsung-backlight etc, doesnt work as well... :-\
im using a samsung n220 marvel plus with ubuntu 10.10.


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 17/02/2011, 22:13 
Newbie
Newbie

Joined: 07/02/2011, 11:42
Posts: 6
That seems to be the same steps I took so I don't have any ideas why your netbook doesn't work.

I can report that after my last post I did two things:

There was a big upgrade, something about recreating my kernel that I installed.

I also changed the time before my NC10+ (alias N150) goes into sleep mode... I made the time a little longer.

My NC10+ is working very well now, all functions keys working and I can also control the brightness. The touchpad works even better than in windows 7.

The only problem that is still bothering me a bit, it's the wireless card loosing connection sometimes.... I've read that it's something to do with the Broadcom card / driver but.... in windows 7 it works ok.... something that Ubuntu is not doing for me....


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 27/02/2011, 16:53 
Newbie
Newbie

Joined: 03/02/2011, 17:52
Posts: 6
it fucks me up now, i am changing the brightness lvl now for several weeks by changing "/sys/class/backlight/samsung/brightness" in console and that sucks^^

can anyone help me to write a script editing this file so that i can bind the script to a key and change brightness this way? shouldnt be too hard i think but my knowledge is very limited in programming...

the script must do the following:
- open /sys/class/backlight/samsung/brightness
- insert the number "7"
- save file
- close file

and then i have to bind this to a key. may anyone help me? :)


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 28/02/2011, 14:59 
Newbie
Newbie

Joined: 17/01/2011, 0:29
Posts: 22
rrsodl wrote:
No idea on any upgrades, sorry.

I wonder how different is your netbook or if this workaround / fix is intended for that model. If it is then can you trace back your steps and make sure you have applied the workaround correctly.

I have expanded the length of time before my netbook goes into suspend mode in power management and that seems to make things better - that confirms to me the problem lies with the power management function


it feels to me as well as if it's a gnome-power-management issue, hinted by the fact that the bug appears differently if the netbook is plugged or not. the workarounds proposed (especially the one where you don't dim the screen when on battery power) greatly reduce the occurence of the bug, and suggesting again a problem with g-p-m. worst case scenario for me is logging out and logging back in, the screen changes brighteness something like 6 times in the process and once in a while it will flicker. on top of it, brightness settings are lost both in the login screen and when logged.

there are a couple of old bug reports in launchpad talking about g-p-m flickering. has anyone reported our problem? is it just g-p-m or the interaction between g-p-m and easy-slow-down-manager?

ciao!
sp


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 04/03/2011, 10:31 
Newbie
Newbie

Joined: 04/03/2011, 10:10
Posts: 1
.dawn wrote:
it fucks me up now, i am changing the brightness lvl now for several weeks by changing "/sys/class/backlight/samsung/brightness" in console and that sucks^^

can anyone help me to write a script editing this file so that i can bind the script to a key and change brightness this way? shouldnt be too hard i think but my knowledge is very limited in programming...

the script must do the following:
- open /sys/class/backlight/samsung/brightness
- insert the number "7"
- save file
- close file

and then i have to bind this to a key. may anyone help me? :)


Hy,

there's no need for writing a script. Just install xbacklight and add keybindings
XF86MonBrightnessDown - xbacklight -dec 15
XF86MonBrightnessUp - xbacklight -inc 15

Cheers,
Merl

_________________
Samsung N130, Ubuntu 10.10, Enlightenment E17 (SVN/easy_e17.sh)


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 04/03/2011, 12:13 
Newbie
Newbie

Joined: 23/11/2009, 14:30
Posts: 14
Backlight worked flawlessly on my n140 with karmic, then it was broken for almost a year, until I updatet on Kubuntu Maverick KDE to version 4.6.0. Since then regulating backlight with the Fn Keys works flawlessly, no flickering, no shit. BUT there's one tiny little detail that's bothering me: if i push the Brightness up or down key, brightness changes TWO steps instead of one. While this is, as I said, only a tiny annoyance I still don't like it. Does anybody know how it's possible to fix this?


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 04/03/2011, 13:20 
Newbie
Newbie

Joined: 04/03/2011, 12:09
Posts: 1
Thanks to this thread, I have finally got the Fn keys working for brightness control. Though it wasn't straightforward (still quite a Linux noob). I am using a Samsung N150 Plus.

First, I added Voria repository to sources (sudo add-apt-repository ppa:voria/ppa), installed samsung-backlight and samsung-tools, then followed these instructions :

1) in /etc/default/grub following line modified from
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor intel_idle.max_cstate=0"
2) sudo update-grub; sudo update-initramfs -u
3) added the following text to the end of /etc/modprobe.d/blacklist.conf: blacklist samsung-backlight
4)edited /etc/rc.local and paste before the "exit 0" statement: modprobe samsung-backlight

This did nothing whatsoever. Others were reporting success, so I assumed it was a PEBKAC error ;)

To confirm this, I ran the checks in the post below, and got no output.

Drake wrote:
The presence of the "acpi_video0" directory is a strong indication of the ACPI driver problem solved by the fix mentioned above. After adding "acpi_backlight=vendor" to your kernel's paramter list it must not (well, it should not) exist.
You might want to check if applying the parameter was successful by running
Code:
sudo dmesg | grep acpi_backlight

Output should look like
Code:
[0.000000] Command Line: ... quiet splash acpi_backlight=vendor
[0.000000] Kernel command line: ... quiet splash acpi_backlight=vendor

If there is no output, the parameter was not applied successfully. You may want to check the GRUB_CMDLINE_LINUX_DEFAULT string, rerun update-grub2 and reboot first.
If there is an output... well, one step at a time. Feel free to post it. :D


I guessed that it was a problem with my grub setup — I was multi-booting windows 7, Peppermint 1, Linux Mint 10, and Pinguy 10.10.1. EasyBCD on windows linked to grub in a separate partition. I followed the above steps on each Linux installation, in case there was a conflict with a 'local' grub, and repeatedly ran sudo update-grub on each installation but it still didn't work.

This took ages, so I gave up and started again. Wiped everything, installed just Pinguy 10.10.1 with grub on MBR. Repeated the steps above, and this time it worked. Then I updated everything that needed updating with Synaptic (including new kernel 2.6.35-28) and broke it again :D Just ran once more: sudo update-grub; sudo update-initramfs -u, rebooted, and it was fixed.

On system resume, I got the flickering screen bug, but it was easily fixed (thanks to ignasigarcia):

ignasigarcia wrote:
I can confirm that if I tell Ubuntu to unload the module before suspend and reload it after restore the blinking occuring sometimes after restoring is gone.

To do so, edit (or create) a file called /etc/pm/config.d/unload_modules

that file must contain a variable declaration and a list of modules separated by empty spaces that we want to unload before suspend. In our case you need to have at least this:

SUSPEND_MODULES="samsung-backlight"

Reboot.

Regards,

Ignacio



The most satisfying thing for me is that I had same problem with brightness control in Win7, and as far as I know there is still no solution. I spent far too long trying to fix that, before deciding that Linux was probably a better bet. Thanks everyone!


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 05/03/2011, 13:14 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
fossean wrote:
Thanks to this thread, I have finally got the Fn keys working for brightness control. Though it wasn't straightforward (still quite a Linux noob). I am using a Samsung N150 Plus.

First, I added Voria repository to sources (sudo add-apt-repository ppa:voria/ppa), installed samsung-backlight and samsung-tools, then followed these instructions :

1) in /etc/default/grub following line modified from
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor intel_idle.max_cstate=0"
2) sudo update-grub; sudo update-initramfs -u
3) added the following text to the end of /etc/modprobe.d/blacklist.conf: blacklist samsung-backlight
4)edited /etc/rc.local and paste before the "exit 0" statement: modprobe samsung-backlight



Hi and thank you very much for these useful instructions.

That worked for my Samsung N150 so thank you. ;)

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 06/03/2011, 13:56 
Newbie
Newbie

Joined: 06/03/2011, 13:33
Posts: 2
Hi,

Kernel: Maverick 10.10 Kernel 2.6.35-24-generic
Samsung: e-251 (Samsung R519/R719)

Everything works fine with the following lines added:

3) added the following text to the end of /etc/modprobe.d/blacklist.conf: blacklist samsung-backlight
4)edited /etc/rc.local and paste before the "exit 0" statement: modprobe samsung-backlight

I still don't use grub 2, but these lines, better described under http://www.voria.org/forum/viewtopic.php?f=3&t=625&start=60 by .dawn, worked well for me.

The new compiled kernel 2.6.35-27 did NOT work for my machine. But i did not delete the lines mentioned above.

Until here, thanks for the work @voria and the additional input @.dawn :)


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 07/03/2011, 21:15 
Newbie
Newbie

Joined: 03/02/2011, 17:52
Posts: 6
good to know that my gathered list helps someone. :)
its a pity it doesnt work for myself... ;)
and xbacklight also doesnt work, nevertheless thanks merl.

no one any idea how to write that script and bind it to the keys?


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 07/03/2011, 22:24 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
I still have the screen flickering sometimes even if i use the tip given by ignasigarcia.

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 09/03/2011, 0:45 
Newbie
Newbie

Joined: 03/02/2011, 17:52
Posts: 6
i've found a solution now thanks to ubuntuusers.de :)
so i want to share here with others ;)

overview about what may be helpful:

first, do the workaround by ignasigarcia:
1) modifiy in /etc/default/grub following line from
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash'
to
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor intel_idle.max_cstate=0"
2) sudo update-grub; sudo update-initramfs -u
3) add the following text to the end of /etc/modprobe.d/blacklist.conf: blacklist samsung-backlight
4) edit /etc/rc.local and paste before the "exit 0" statement: modprobe samsung-backlight
5) create a file called /etc/pm/config.d/unload_modules containing: SUSPEND_MODULES="samsung-backlight"

if this doesn't help to change the brightness with fn-keys, try the following:
(be careful, editing visudo is bit risky)

a) sudo visudo
b) paste at the end of this file the following line (attention: there must be one blank line after this):
ALL ALL=NOPASSWD: /usr/bin/tee /sys/class/backlight/samsung/brightness
c) go to system -> settings -> key combination/shortcuts
and make a new shortcut with the command:
sh -c "echo 7 | sudo tee /sys/class/backlight/samsung/brightness"
d) bind it to a shortcut of your choice

with this shortcut you can now increase your brightness :)

e) if you want to make another shortcut for decreasing brightness, just make another shortcut with the command:
sh -c "echo 0 | sudo tee /sys/class/backlight/samsung/brightness"

if someone wants to know, what these steps do:
by editing visudo you give all users the authorisation to overwrite /sys/class/backlight/samsung/brightness with the program "tee" without password. thats it, the binding just shorten it to a special key.

hope this will help someone :)


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 09/03/2011, 9:47 
Newbie
Newbie

Joined: 09/03/2011, 9:13
Posts: 1
Hello,
I'm owner of Samsung NP-N150-JP01PL.
In my case after installing samsung-backlight and samsung-tools I use following sollution with success:

1. edit /etc/default/grub
Code:
sudo nano /etc/defautl/grub

2. change line from
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

to
Code:
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

3. update grub
Code:
sudo update-grub2

4. create file /etc/modprobe.d/samsung-backlight.conf
Code:
sudo nano /etc/modprobe.d/samsung-backlight.conf

5. insert into this file following line and save it
Code:
options samsung_backlight use_sabi=0 force=1

6. reboot the system

This solution was checked under GNOME and KDE and in both it works perfectly.
Naturally you can use your favourite text editor instead of nano.


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 11/03/2011, 13:47 
Newbie
Newbie

Joined: 11/03/2011, 13:34
Posts: 2
Hi, I have a N150 Plus and changing the backlight does not work. I tried different fixes and workarounds from this thread, but nothing works.

I can turn on/off backlight with Fn+F5 and I can change the backlight if I change the value in /sys/class/backlight/samsung/brightness. But Fn+up/down does not work

I use Maverick with Unity Desktop


Top
 Profile  
 
 Post subject: Re: Backlight doesn't work with latest Maverick kernel
PostPosted: 12/03/2011, 11:39 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
Hi burli,

you can try with an older kernel.

Read this : viewtopic.php?f=3&t=728

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 84 posts ]  Go to page Previous  1, 2, 3, 4, 5, 6  Next

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net & kodeki