Last visit was: It is currently 22/10/2014, 5:50


All times are UTC [ DST ]




Post new topic Reply to topic  [ 14 posts ] 
Author Message
 Post subject: Hard drives stops responding when on battery
PostPosted: 04/04/2011, 22:27 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
Hi,

I'm having a really strange problem on my new NF310
I successfully installed Ubuntu on the netbook, when i was connected to the power-supply.
So when installed, i took it off, and installed new software, surfed.. on battery..
suddenly nothing wanted to run, etc..
good thing i got an terminal open so i ran dmesg and got output that he had problems writing to the hard-drive.
Other commands didn't work with the normal error that it had input output problems..
i got this every time.. i rebooted.. it boots ok.. but suddenly when working on it.. it happens..

so.. i guess something went wrong in power-management of the hard-drive?

I'm now booted in windows, to verify if i can reproduce it overhere.. but it seems stable here..

note, i had this problem before and after bios update (found an bios update), didn't fix it..

so i'm thinking acpi of the harddrive?


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 04/04/2011, 23:11 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
Wow :eek:

Very strange issue, i will report here if i find something to help you.

I would say that your hard disk falls to sleep mode because of the battery mode for powersaving.

The fact is it doesn't wake up.

ACPI would be a good way to start research about this issue.

Could you put here the informations given by dmesg please ?

edit : and informations given by

Code:
HWinfo --disk

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 04/04/2011, 23:26 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
Hi

Thanks for the quick response!

Now i'm on windows for a couple of hours (eek)
and sometimes it seems to stutter.. could be the fact its windows..
or it could be it is trying to kickstart the drive again somehow..

So, extra info: i had the problem before and after the samsung tools and other packages from the ppa where installed..

It could also be i have a foobar hard-drive..

I'll try to get the dmesg :) (not easy to write it away when drive ain't responding..)
i think if i have also an ssh open.. i need to be able to save it :)

first i thought it was an filesystem issue.. but then i noticed i only have the problem when on battery..
note i disabled the harddrive sleep in power management so.. it shouldn't be going to sleep..

again.. could be foobar drive.. and it will be format 7 times and RMA :)
but then again.. it should also fail then on battery.. so idd.. place we need to search ACPI
I guess one of the first things is disable acpi on boot..
oh yeah.. since i upgraded to your kernel version sleepmode doesn't seem to work anymore.. but backlight is working like a charm :)

Thanks for the help! (great i found this forum)


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 05/04/2011, 21:32 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
Hi, so i was able to replicate it and save it via ssh :)

here it is:
note: hwinfo was run when drive was ok
dmesg was limited cause framebuffer..
Code:
> hal.1: read hal dataprocess 2028: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 280.
This is normally a bug in some application using the D-Bus library.
libhal.c 3483 : Error unsubscribing to signals, error=The name org.freedesktop.Hal was not provided by any .service files
21: IDE 00.0: 10600 Disk                                       
  [Created at block.243]
  Unique ID: 3OOL.8MZXfAWnuH8
  Parent ID: w7Y8.1T_0outZkp6
  SysFS ID: /class/block/sda
  SysFS BusID: 0:0:0:0
  SysFS Device Link: /devices/pci0000:00/0000:00:1f.2/host0/target0:0:0/0:0:0:0
  Hardware Class: disk
  Model: "Hitachi HTS54322"
  Vendor: "Hitachi"
  Device: "HTS54322"
  Revision: "ESBO"
  Driver: "ahci", "sd"
  Driver Modules: "ahci"
  Device File: /dev/sda
  Device Files: /dev/sda, /dev/block/8:0, /dev/disk/by-id/ata-Hitachi_HTS543225A7A384_E2021342GZZD1J, /dev/disk/by-id/scsi-SATA_Hitachi_HTS5432_E2021342GZZD1J, /dev/disk/by-path/pci-0000:00:1f.2-scsi-0:0:0:0, /dev/disk/by-id/wwn-0x5000cca614ce1535
  Device Number: block 8:0-8:15
  BIOS id: 0x80
  Drive status: no medium
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (SATA controller)




[   94.974518] end_request: I/O error, dev sda, sector 255353832
[  103.143868] sd 0:0:0:0: [sda] Unhandled error code
[  103.143890] sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  103.143908] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 17 70 f1 00 00 00 80 00
[  103.143951] end_request: I/O error, dev sda, sector 393277696
[  103.144051] EXT4-fs error (device sda5): __ext4_get_inode_loc: inode #5242881: (comm mutter) unable to read inode block 20971552
[  110.674880] CE: hpet increased min_delta_ns to 16875 nsec
[  261.113041] sd 0:0:0:0: [sda] Unhandled error code
[  261.113057] sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  261.113075] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 0f 45 86 b8 00 00 20 00
[  261.113118] end_request: I/O error, dev sda, sector 256214712
[  261.113270] sd 0:0:0:0: [sda] Unhandled error code
[  261.113283] sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  261.113299] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 0f 45 86 b8 00 00 08 00
[  261.113339] end_request: I/O error, dev sda, sector 256214712
[  282.726396] sd 0:0:0:0: [sda] Unhandled error code
[  282.726407] sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  282.726419] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 0f 45 86 b8 00 00 08 00
[  282.726447] end_request: I/O error, dev sda, sector 256214712
[  286.060448] sd 0:0:0:0: [sda] Unhandled error code
[  286.060461] sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  286.060477] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 15 f1 f1 08 00 00 08 00
[  286.060508] end_request: I/O error, dev sda, sector 368177416
[  286.060584] EXT4-fs error (device sda5): ext4_find_entry: inode #4456450: (comm bash) reading directory lblock 0
[  286.069568] sd 0:0:0:0: [sda] Unhandled error code
[  286.069581] sd 0:0:0:0: [sda] Result: hostbyte=DID_BAD_TARGET driverbyte=DRIVER_OK
[  286.069594] sd 0:0:0:0: [sda] CDB: Read(10): 28 00 15 f1 f1 08 00 00 08 00
[  286.069626] end_request: I/O error, dev sda, sector 368177416
[  286.069691] EXT4-fs error (device sda5): ext4_find_entry: inode #4456450: (comm bash) reading directory lblock 0


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 06/04/2011, 9:07 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
I forgot some questions.

Which Ubuntu ?

Kernel used ?
Code:
cat /proc/version

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 24/04/2011, 14:58 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
Hi,

Sorry for the late reply, had some busy weeks.
the proc version is
Quote:
Linux version 2.6.35-28-generic (buildd@kutjera) (gcc version 4.4.5 (Ubuntu/Linaro 4.4.4-14ubuntu5) ) #51~ppa1~loms~maverick-Ubuntu SMP Thu Apr 21 23:31:16 UTC 2011

i'm using the netbook version of ubuntu and your kernel repo.
now with this kernel it seems more stable
i do see this error in dmesg:
Quote:
[ 125.212256] ACPI Error (psargs-0359): [\_SB_.VDRV] Namespace lookup failure, AE_NOT_FOUND
[ 125.212274] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.LPC0.H_EC._Q52] (Node f701f648), AE_NOT_FOUND

but i guess this is not any critical thing


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 24/04/2011, 15:28 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
i stand corrected..
the bug is still there..
hard-disk is not responding anymore


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 08/05/2011, 18:22 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
maybe this
Quote:
[ 2001.384331] ACPI Error: [\_SB_.VDRV] Namespace lookup failure, AE_NOT_FOUND (20110112/psargs-359)
[ 2001.384353] ACPI Error: Method parse/execution failed [\_SB_.PCI0.LPC0.H_EC._Q52] (Node f4c26648), AE_NOT_FOUND (20110112/psparse-536)


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 11/05/2011, 22:02 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
Currently, i'm too busy to catch some answers for your problem.

But did you try with Ubuntu 11.04 ?

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 16/05/2011, 21:54 
Newbie
Newbie

Joined: 16/05/2011, 21:41
Posts: 1
Hi,

here's a link to the translation of a small tutorial i wrote about installing ubuntu 10.10 on my samsung NF310.

I never had a probleme like yours.

I hope it can help you.

http://translate.google.fr/translate?js ... buntu.html


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 05/09/2011, 21:31 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
Ok.. sended the netbook 3 times to samsung.. still have the same issues..
when on battery.. the disk suddenly dies..

1st time they claim they replaced the disk.. but for what i see the serial number is the same..
2nd time they just formatted it..
3rd time they replaced the battery..

*sigh* will be sending it back a 4th time with an angry letter and phonecall.. i have this device for about 5 months, and haven't been able to do anything with it.. I'm very disappointed :(


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 05/09/2011, 21:58 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
And did you try with a fresh install (11.04 or maybe try beta 11.10) without setting up voria packages/kernel ?

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 06/09/2011, 14:18 
Newbie
Newbie

Joined: 04/04/2011, 22:10
Posts: 8
Woulouf wrote:
And did you try with a fresh install (11.04 or maybe try beta 11.10) without setting up voria packages/kernel ?


i have it with fresh install 11.04, before and after voria package..
on adaptor no problems, on battery harddisk dies..
This is not my first linux install.. something fisshie is going on..


Top
 Profile  
 
 Post subject: Re: Hard drives stops responding when on battery
PostPosted: 06/09/2011, 15:59 
Supporter
Supporter
User avatar

Joined: 05/03/2011, 12:32
Posts: 51
Location: France
Well, it could be a case where your HDD goes into sleep mode but doesn't want to wake up.

Let's try to find a way to solve this issue with hdparm

Get full informations about your HDD with :

Code:
sudo hdparm -I /dev/sda


And you can check the status of your HDD once on DC power and once on Battery mode with

Code:
sudo hdparm -C /dev/sda

_________________
Samsung N150 powered by Voyager 12.04 (Xubuntu)
Brightness control issue with 12.04 LTS : look at this topic viewtopic.php?p=5753#p5753


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 14 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net & kodeki