Last visit was: It is currently 20/10/2014, 14:04


All times are UTC [ DST ]




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Backlight on Q430 working
PostPosted: 10/06/2011, 17:15 
Newbie
Newbie

Joined: 10/06/2011, 17:05
Posts: 5
I FINALLY got backlight working on my Q430 in Arch Linux. This solution SHOULD work for other Nvidia backlight laptops: that is those with Nvidia chipsets.

Download and install nvidia_bl for your distro. For Arch this is available in AUR. I'm not using the DKMS version.

Load the nvidia_bl module
Code:
$ sudo modprobe nvidia_bl


If it doesn't return any errors you've got it, now you need to have it load at boot time. In arch this involves putting it in rc.conf in the modules=() section. I'm not sure on other distros.

Here's the catch:
Code:
$ ls /sys/class/backlight

on my system it listed TWO directories (three if you install samsung backlight stuffs)
Code:
 acpi_video0/      nvidia_backlight/


Pressing the fn+up keys did pop up with an indicator, so I investigated:
Code:
 $ cat /sys/class/backlight/acpi_video0/brightness
7


pressed fn+down a few times

Code:
 $ cat /sys/class/backlight/acpi_video0/brightness
4


A HAH! The fn+brightness keys were outputting to the wrong damned hardware (probably the intel hardware). So I do the following

Code:
 $ rmmod video samsung_backlight


Now my fn+backlight keys WORK!

We need to blacklist those modules to keep them from loading. In arch you add a file to /etc/modprobe.d/ with the following lines in it
Code:
blacklist video
blacklist samsung_backlight


Though I'll probably just remove samsung-tools from my system as there don't appear to be any advantages to keeping it.

I hope this helps anyone else with the crazy freakin' nvidia backlight modules. Should depricate the "make a shell script" insanity.

Cheers.


Top
 Profile  
 
 Post subject: Re: Backlight on Q430 working
PostPosted: 10/06/2011, 17:28 
Newbie
Newbie

Joined: 10/06/2011, 17:05
Posts: 5
After reverting several other backlight solutions I discovered the following was also necessary:

a modprobe file describing the backlight states of the nvidia_bl module. I made a file at /etc/modprobe.d/nvidia_bl.conf and wrote the following into it:
Code:
options nvidia_bl max_level=0x1ffff shift=11


Top
 Profile  
 
 Post subject: Re: Backlight on Q430 working
PostPosted: 03/12/2012, 0:14 
Newbie
Newbie

Joined: 03/12/2012, 0:08
Posts: 1
The only reason i have registered on this forum is to thank you! I had no freakin idea, which module created that @#%#% other directory, but blacklisting video module helped (i haven't installed samsung tools, so i didn't have the samsung_backlight)

Great post, saved me so much headache! Works fine! Samsung RV420 - nvidia GT520m /although it's paper claims to be an optimus, there is NO Intel card working in this one, just a single nvidia./


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC [ DST ]


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
Theme created StylerBB.net & kodeki